Back to overview
Degraded
Delay in delivering emails
Dec 19 at 03:38pm EST
Affected services
Hubstaff Account
Hubstaff Tasks
Hubstaff Talent
Resolved
Dec 19 at 07:27pm EST
Our transactional email services provider Mailchimp fixed issues on their end. Email delivery services functionality restored.
Affected services
Hubstaff Account
Hubstaff Talent
Hubstaff Tasks
Created
Dec 19 at 03:38pm EST
Our SMTP service provider, Mailchimp, is currently experiencing an issue that is affecting our ability to deliver email messages.
We are currently investigating the issue with Mailchimp technical support team.
We will resolve this incident once we have received confirmation the issue has been resolved from our SMTP service provider.
Affected services
Hubstaff Account
Hubstaff Talent
Hubstaff Tasks