Back to overview
Degraded

Delay in delivering emails

Mar 01 at 08:18am EST
Affected services
Hubstaff Dashboard

Resolved
Mar 01 at 10:35am EST

We're closing the incident as we haven't seen any failed email deliveries for longer than an hour now.

Updated
Mar 01 at 09:42am EST

We're seeing a decrease in the rate of errors. Our engineers keep monitoring the system.

We will resolve the incident when we confirm there are no failed email deliveries.

Created
Mar 01 at 08:18am EST

Our SMTP service provider, Mailchimp, is currently experiencing an issue that is affecting our ability to deliver email messages.

We are currently investigating the issue with Mailchimp technical support team.

We will resolve this incident once we have received confirmation the issue has been resolved from our SMTP service provider.